Sun, 24 Oct 2021 08:52:08 PDT | login

Information for build python-avocado-82.0-2.fc33

ID195996
Package Namepython-avocado
Version82.0
Release2.fc33
Epoch
SummaryFramework with tools and libraries for Automated Testing
DescriptionAvocado is a set of tools and libraries (what people call these days a framework) to perform automated testing.
Built bydavidlt
State complete
Volume DEFAULT
StartedWed, 06 Oct 2021 22:27:17 PDT
CompletedWed, 06 Oct 2021 22:27:17 PDT
Tags
f33
RPMs
src
python-avocado-82.0-2.fc33.src.rpm (info) (download)
noarch
python-avocado-bash-82.0-2.fc33.noarch.rpm (info) (download)
python-avocado-common-82.0-2.fc33.noarch.rpm (info) (download)
python-avocado-examples-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-glib-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-golang-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-loader-yaml-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-output-html-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-result-upload-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-resultsdb-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-varianter-cit-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-varianter-pict-82.0-2.fc33.noarch.rpm (info) (download)
python3-avocado-plugins-varianter-yaml-to-mux-82.0-2.fc33.noarch.rpm (info) (download)
Changelog * Thu Mar 18 2021 Merlin Mathesius <mmathesi@redhat.com> - 82.0-2 - Drop obsolete packages from BuildRequires - Generate man page directly using 'rst2man' rather than requiring 'make' - Adjust PATH to make sure self-tests find internal modules - Spec file cleanup following package review. * Mon Sep 14 2020 Cleber Rosa <cleber@redhat.com> - 82.0-1 - Sync with upstream release 82.0. - Removed python libvirt depedency as the vm runner has been removed upstream - Dropped configuration files to sync with upstream which made them optional and doesn't ship them anymore - Add on extra character to short commit to sync with upstream * Sat Jun 06 2020 Cleber Rosa <cleber@redhat.com> - 80.0-1 - Sync with upstream release 80.0. - Dropped use of custom avocado command for tests - Do not build deprecated runners * Tue May 12 2020 Cleber Rosa <cleber@redhat.com> - 79.0-1 - Sync with upstream release 79.0. - Added Python's user base bin dir to the PATH environment variable while running tests, so that avocado-runner-* scripts can be found - Moved comment to new lines closing the conditionals, to avoid errors from rpmlint and rpmbuild * Wed Apr 15 2020 Merlin Mathesius <mmathesi@redhat.com> - 78.0-1 - Sync with upstream release 78.0. * Tue Mar 17 2020 Merlin Mathesius <mmathesi@redhat.com> - 77.0-1 - Sync with upstream release 77.0. * Mon Mar 09 2020 Merlin Mathesius <mmathesi@redhat.com> - 76.0-1 - Sync with upstream release 76.0. * Mon Jan 20 2020 Merlin Mathesius <mmathesi@redhat.com> - 75.1-1 - Sync with upstream release 75.1. * Mon Dec 23 2019 Merlin Mathesius <mmathesi@redhat.com> - 74.0-1 - Sync with upstream release 74.0. * Wed Nov 27 2019 Merlin Mathesius <mmathesi@redhat.com> - 73.0-1 - Sync with upstream release 73.0. - Adjustments to build for RHEL 8. * Wed Oct 02 2019 Merlin Mathesius <mmathesi@redhat.com> - 72.0-1 - Sync with upstream release 72.0. * Wed Aug 28 2019 Merlin Mathesius <mmathesi@redhat.com> - 71.0-1 - Sync with upstream release 71.0. * Wed Jun 26 2019 Merlin Mathesius <mmathesi@redhat.com> - 70.0-1 - Sync with upstream release 70.0. - Drop all Python 2 support from SPEC file. * Wed May 22 2019 Merlin Mathesius <mmathesi@redhat.com> - 69.0-4 - pyliblzma is Python 2-only and no longer available as of F31. - Unversioned executables should now be Python 3. * Mon May 20 2019 Merlin Mathesius <mmathesi@redhat.com> - 69.0-3 - Drop Python 2 support from F31 and RHEL8 onward. - Disable components dependent upon Fiber in Fedora 31 and later, since avocado is currently incompatible with the new Fiber API. * Tue Mar 19 2019 Merlin Mathesius <mmathesi@redhat.com> - 69.0-2 - python2-sphinx is no longer available or needed as of F31